Gutenberg : Daniel Bachhuber monte une bibliothèque de compatibilité des plugins

4 mars 2018    |   par Ben Cousin

Pour qui s’intéresse de près ou de loin à WordPress, Gutenberg est LE sujet qui revient sur toutes les lèvres depuis quelques mois.

C’est assez normal : il s’agit en l’espèce de modifier intégralement l’interface de gestion de notre CMS préféré, et son fonctionnement.  Autant dire que le lancement de la version WordPress 5.0, qui embarquera en principe Gutenberg, va bien changer la vie des utilisateurs.

Les indicateurs semblent plutôt bons, et tous les articles un peu pointus que je lis sur le sujet indiquent une révolution vraiment positive.

Sur le papier, nous n’avons donc en principe qu’à nous réjouir de l’arrivée de Gutenberg.

Toutefois, comme nous ne développons pas nos sites web sur du papier, les choses ne sont évidemment pas si simples. Gutenberg va imposer de nouvelles contraintes et nécessiter un certain nombre d’adaptations.

La question des plugin, notamment, est un sujet véritablement important :  seront t-il compatibles ?  Autrement dit, dans le nouvel écosystème imposé par Gutenberg, pourrons-nous utiliser nos outils habituel ? Pourrons-nous les conserver sur les sites déjà livrés ?

Daniel Bachhuber est un membre actif de la communauté WordPress, fortement impliqué dans le Projet Gutenberg. Pour répondre à cette problématique, il vient de lancer une bibliothèque crowdsourcée, qui recensera au fil du temps l’état de compatibilité des principaux plugins référencés.

Dans son annonce du 1er mars 2018, Bachhuber laisse peu de place au doute quant aux ennuis à prévoir en cas d’incompatibilités :

« But plugins! If any one of their active plugins are incompatible with Gutenberg, the WordPress user is likely to experience pain, misery, and bad fortune »

Je ne traduis pas : si vous comprenez « misery » vous avez compris l’essentiel.

Pour l’équipe de développement du Core WordPress, l’objectif de cette base de données est double :

  1. Informer la communauté des développeurs de la compatibilité d’un plugin X ou Y au temps T
  2. Récolter l’information pour eux-mêmes

Pour le point deux, il s’agit d’identifier les difficultés dans une perspective didactique d’accompagnement ultérieur :

  • Comprendre les principales causes d’incompatibilité
  • Sensibiliser les développeurs sur les points les plus impactant
  • Éduquer les utilisateurs de WordPress de façon proactive, pour les amener à anticiper et à préparer leur installations pour Gutenberg.

L’essentiel étant dit, je vous invite à découvrir le projet Gutenberg Plugin Compatibility.

Dans la même rubrique
Happy 30%, WordPress !

29.9%… — Matt Mullenweg (@photomatt) March 2, 2018 La plateforme de gestion de contenus par excellence Si vous pensiez que WordPress ne concerne que les petits blogs amateurs, détrompez-vous ! Ce CMS a su convaincre même les plus grands acteurs de ce monde. Des preuves ? Si je vous dis que même la Maison Blanche […]

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Besoin d'un expert ?

N'hésitez pas à nous contacter pour plus de renseignements
Adresse

21, rue du Chai des Farines - 33000 Bordeaux

Contact global

benjamin@xpdigital.fr

Téléphone

+33 (0) 664 883 629

Vous avez un projet ?